blog.powershell.no

On Windows PowerShell and other admin-related topics

Outlook Web Access not working after applying an Exchange 2007 Update Roll-up

I`ve just installed Update Roll-up 7 for Exchange 2007 SP1, and afterwards the Outlook Web Access showed a blank page and there was a yellow exclamation mark in the bottom left corner, which stated “syntax error on line 6 of login.aspx”.

I first tried the solution Microsoft provided in this support forum thread, although it didn`t work for me.
I had to re-create the OWA Virtual directory.

I accomplished this using these two PowerShell commands from the Exchange Management Shell:

image

image

Actually the Microsoft Exchange Team stated the following reminder in the blog post regarding Update Roll-up 7:

“And finally, from the installation perspective, a friendly reminder that the roll-up installer will overwrite any OWA script files if required to ensure proper operation of OWA. So if you have customized the logon.aspx page or other similar OWA pages, you will need to redo any customization after installation of the roll-up.”

My recommendation would be to backup the C:\Program Files\Microsoft\Exchange Server\ClientAccess\OWA folder before installing an Exchange 2007 Update Roll-up.

Advertisements

March 23, 2009 - Posted by | Exchange Server 2007, Exchange Server management

1 Comment »

  1. Hi there.

    Thanks a million for the advice. been up all nite hacking this thing!

    These update rollups suck!

    Comment by samuel | March 26, 2010 | Reply


Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s

%d bloggers like this: